re = /(.)(?!\1)(.)(?!\1)(?!\2)(.)(?!\1)(?!\2)(?!\3)(.)(?!\1)(?!\2)(?!\3)(?!\4)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(?!\12)(.)(?!\1)(?!\2)(?!\3)(?!\4)(?!\5)(?!\6)(?!\7)(?!\8)(?!\9)(?!\10)(?!\11)(?!\12)(?!\13)(.)/m
str = 'mjqjpqmgbljsphdztnvjfqwrcgsmlb: first marker after character 19
bvwbjplbgvbhsrlpgdmjqwftvncz: first marker after character 23
nppdvjthqldpwncqszvftbrmjlhg: first marker after character 23
nznrnfrfntjfmvfwmzdfjlvtqnbhcprsg: first marker after character 29
zcfzfwzzqfrljwzlrfnpqdbhtmscgvjw: first marker after character 26
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end