const regex = /#(?=item)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(?=item)', 'gm')
const str = `#333 /*do not track*/
#ff0000 /*do not track*/
#item1 /*found*/
#item2 /*found*/
#item3 /*found*/
#item /*found*/
#item /*found*/
#item /*found*/`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);