$re = '/#(?=item)/m';
$str = '#333 /*do not track*/
#ff0000 /*do not track*/
#item1 /*found*/
#item2 /*found*/
#item3 /*found*/
#item /*found*/
#item /*found*/
#item /*found*/';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;