const regex = /(?P<section>(første|annen|andre|annet|tredje|fjerde|femte)(?=(\sledd|\sog\s(første|annen|andre|annet|tredje|fjerde|femte)\ssection|,\s(første|annen|andre|annet|tredje|fjerde|femte))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<section>(første|annen|andre|annet|tredje|fjerde|femte)(?=(\\sledd|\\sog\\s(første|annen|andre|annet|tredje|fjerde|femte)\\ssection|,\\s(første|annen|andre|annet|tredje|fjerde|femte))))', 'g')
const str = `først noe annet så. Straffeloven § 444 annet, tredje, første og fjerde section. fjerde noe annet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}