$re = '/(?P<section>(første|annen|andre|annet|tredje|fjerde|femte)(?=(\sledd|\sog\s(første|annen|andre|annet|tredje|fjerde|femte)\ssection|,\s(første|annen|andre|annet|tredje|fjerde|femte))))/J';
$str = 'først noe annet så. Straffeloven § 444 annet, tredje, f ørste og fjerde section. fjerde noe annet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);