import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\}]*name:[^\\}]*\\bthe\\b[^\\}]*\\}";
final String string = "{\n"
+ "id: 1\n"
+ "locID: A\n"
+ "tStart: 17:10:00\n"
+ "tEnd: 17:35:00\n"
+ "name: the man 45\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 2\n"
+ "locID: A\n"
+ "tStart: 17:11:00\n"
+ "tEnd: 17:12:00\n"
+ "name: Frank\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 3\n"
+ "locID: A\n"
+ "tStart: 17:11:00\n"
+ "tEnd: 17:14:00\n"
+ "name: there Frank\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 4\n"
+ "locID: B\n"
+ "tStart: 17:51:00\n"
+ "tEnd: 17:56:00\n"
+ "name: the woman 2\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 5\n"
+ "locID: A\n"
+ "tStart: 17:11:00\n"
+ "tEnd: 16:11:00\n"
+ "name: the man with the golden gun\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 6\n"
+ "locID: C\n"
+ "tStart: 17:11:00\n"
+ "tEnd: 17:11:00\n"
+ "name: the woman with the dragon tattoo\n"
+ "text: Lorum Ipsum\n"
+ "}\n"
+ "{\n"
+ "id: 7\n"
+ "locID: A\n"
+ "tStart: 17:15:00\n"
+ "tEnd: 17:15:00\n"
+ "name: Jo\n"
+ "text: Lorum Ipsum\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}