# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{[^}]*name:[^}]*\bthe\b[^}]*}"
test_str = ("{\n"
"id: 1\n"
"locID: A\n"
"tStart: 17:10:00\n"
"tEnd: 17:35:00\n"
"name: the man 45\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 2\n"
"locID: A\n"
"tStart: 17:11:00\n"
"tEnd: 17:12:00\n"
"name: Frank\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 3\n"
"locID: A\n"
"tStart: 17:11:00\n"
"tEnd: 17:14:00\n"
"name: there Frank\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 4\n"
"locID: B\n"
"tStart: 17:51:00\n"
"tEnd: 17:56:00\n"
"name: the woman 2\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 5\n"
"locID: A\n"
"tStart: 17:11:00\n"
"tEnd: 16:11:00\n"
"name: the man with the golden gun\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 6\n"
"locID: C\n"
"tStart: 17:11:00\n"
"tEnd: 17:11:00\n"
"name: the woman with the dragon tattoo\n"
"text: Lorum Ipsum\n"
"}\n"
"{\n"
"id: 7\n"
"locID: A\n"
"tStart: 17:15:00\n"
"tEnd: 17:15:00\n"
"name: Jo\n"
"text: Lorum Ipsum\n"
"}")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.