#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/export/home/[^/]*(?:/(?!export/home/)[^/]*)*"
Local $sString = "/export/home/bla "123" "bla" test 1" & @CRLF & _
"/export/home/bla "123" "bla" test 2" & @CRLF & _
"/export/home/bla "123" "bla" test 3" & @CRLF & _
"test4" & @CRLF & _
"test5" & @CRLF & _
"/export/home/bla "123" "bla" test 6" & @CRLF & _
"/export/home/bla "123" "bla" test 7" & @CRLF & _
"/export/home/bla "123" "bla" test 8" & @CRLF & _
"test9" & @CRLF & _
"/export/home/bla "123" "bla" test 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")