# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/export/home/[^/]*(?:/(?!export/home/)[^/]*)*"
test_str = ("/export/home/bla \"123\" \"bla\" test 1\n"
"/export/home/bla \"123\" \"bla\" test 2\n"
"/export/home/bla \"123\" \"bla\" test 3\n"
"test4\n"
"test5\n"
"/export/home/bla \"123\" \"bla\" test 6\n"
"/export/home/bla \"123\" \"bla\" test 7\n"
"/export/home/bla \"123\" \"bla\" test 8\n"
"test9\n"
"/export/home/bla \"123\" \"bla\" test 1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.