#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?(\d+)$"
Local $sString = "2^64" & @CRLF & _
"asdgaf1_hsg534" & @CRLF & _
"asdfh23_hsjd12" & @CRLF & _
"dgshg_jhfsd86" & @CRLF & _
"test"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)