import re
regex = re.compile(r"^.*?(\d+)$", flags=re.MULTILINE)
test_str = ("2^64\n"
"asdgaf1_hsg534\n"
"asdfh23_hsjd12\n"
"dgshg_jhfsd86\n"
"test")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)