const regex = /^(?:(?!xyz|1).)*1.*xyz.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!xyz|1).)*1.*xyz.*', 'gm')
const str = `Anytext1 Anytext2 xyz Anytext1 xyz AnyText1 xyz
Anytext1 1Anytext2 xyz Anytext1 xyz AnyText1 xyz
Anytext0 Anytext2 xyz AnyText1 xyz Anytext1 xyz AnyText1 xyz AnyText1 xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}