$re = '/^(?:(?!xyz|1).)*1.*xyz.*/m';
$str = 'Anytext1 Anytext2 xyz Anytext1 xyz AnyText1 xyz
Anytext1 1Anytext2 xyz Anytext1 xyz AnyText1 xyz
Anytext0 Anytext2 xyz AnyText1 xyz Anytext1 xyz AnyText1 xyz AnyText1 xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);