$re = '/(?:\w+ ){0,2}Road\b/m';
$str = 'McDonald\'s, King Dinuzulu Road, Durban
Queens Road, Cape Town';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);