re = /(?:\w+ ){0,2}Road\b/m
str = 'McDonald\'s, King Dinuzulu Road, Durban
Queens Road, Cape Town'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end