$re = '/(?:(?:thing\.|stuff\.)\s*Some)|(^\s*Some)/m';
$str = 'Some thing.
Some other text.
Some line.
Some additional text.
Some stuff.
Some additional text.
Some additional text.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);