import re
regex = re.compile(r"(?:(?:thing\.|stuff\.)\s*Some)|(^\s*Some)", flags=re.MULTILINE)
test_str = ("Some thing.\n"
" Some other text.\n"
" Some line.\n"
" Some additional text.\n"
"Some stuff.\n"
" Some additional text.\n"
"Some additional text.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")