import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]:\\\\Windows\\\\SysWOW64\\\\Macromed\\\\Temp\\\\\\{[a-zA-Z0-9]{0,8}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,12}\\}\\\\InstallFlashPlayer.exe";
final String string = "C:\\Windows\\SysWOW64\\Macromed\\Temp\\{CE4BD592-D1BB-4C22-9428-FF632509F73F}\\InstallFlashPlayer.exe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}