$re = '/^[a-zA-Z]:\\\\Windows\\\\SysWOW64\\\\Macromed\\\\Temp\\\\{[a-zA-Z0-9]{0,8}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,4}-[a-zA-Z0-9]{0,12}}\\\\InstallFlashPlayer.exe/m';
$str = 'C:\\Windows\\SysWOW64\\Macromed\\Temp\\{CE4BD592-D1BB-4C22-9428-FF632509F73F}\\InstallFlashPlayer.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);