import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{10,}(.*)$";
final String string = "'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001',\n"
+ "'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001',\n"
+ "'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001',\n"
+ "'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001',";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}