$re = '/\d{10,}(.*)$/m';
$str = '\'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001\',
\'Firstname Lastname lorem@gmail.com 0000243598 0000243598 CAB pilote 001 001\',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);