$re = '/^.{0,20}/m';
$str = 'This string has more than 20 characters
This one\'s short
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);