re = /^.{0,20}/m
str = 'This string has more than 20 characters
This one\'s short
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end