$re = '/^(\S+)/m';
$str = 'abc 123 tr
abd1 124 tr
abce 126 af
abe 128 nm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);