$re = '/^(?!.*news\.aspx$).+$/mi';
$str = 'asdfasd.sdf
asdfbsfb.sgasg
asfbadfb.adfbadfb
aadsfasf.news.aspasfd
aadsfasf.news.asPx
aadsfasf.news.aspasfd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);