re = /^(?!.*news\.aspx$).+$/mi
str = 'asdfasd.sdf
asdfbsfb.sgasg
asfbadfb.adfbadfb
aadsfasf.news.aspasfd
aadsfasf.news.asPx
aadsfasf.news.aspasfd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end