const regex = /(?<=\bmysql(?: --[^\s=]+=[^\s=]+)* --[^\s=]+=)[^\s=]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bmysql(?: --[^\\s=]+=[^\\s=]+)* --[^\\s=]+=)[^\\s=]+', 'gm')
const str = `mysql --user=USER_NAME --host=DB_HOST --database=SCHEMA -p -e 'SELECT
mysql --user=USER_NAME --host=DB_HOST --database=SCHEMA`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);