import Foundation
let pattern = #"(?<=\bmysql(?: --[^\s=]+=[^\s=]+)* --[^\s=]+=)[^\s=]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mysql --user=USER_NAME --host=DB_HOST --database=SCHEMA -p -e 'SELECT
mysql --user=USER_NAME --host=DB_HOST --database=SCHEMA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)