$re = '/(?<=^classes!\("(?:[^"]*"[^"()]*")*)[^"]*/m';
$str = 'classes!("text-xl", "text-blue-500")
String::from("test")
classes!("text-sm")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);