re = /(?<=^classes!\("(?:[^"]*"[^"()]*")*)[^"]*/m
str = 'classes!("text-xl", "text-blue-500")
String::from("test")
classes!("text-sm")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end