#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<=")\s*(?:https?)?:\/\/[^"]+\/(?=[^"]*logo)[^"]*(?:png|jpe?g|gif|tiff)\s*(?=")"
Local $sString = "<link rel="icon" href="https://diabsolut.com/wp-content/uploads/2018/02/D-Logo-150x150.png" sizes="32x32">" & @CRLF & _
"<link rel="icon" href="https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png" sizes="192x192">" & @CRLF & _
"<link rel="apple-touch-icon-precomposed" href="https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png">" & @CRLF & _
"<meta name="msapplication-TileImage" content="https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png">" & @CRLF & _
"<img width="200" height="147" src="https://diabsolut.com/wp-content/uploads/2017/05/Diabsolut-logo-01-e1496083111444.png" class="attachment-large size-large" alt="">" & @CRLF & _
"<img src="https://diabsolut.com/wp-content/uploads/2019/03/White-FSM-logo.png" width="330" height="215" data-no-retina="" style="">" & @CRLF & _
"" & @CRLF & _
"<img src="https://diabsolut.com/wp-content/uploads/2017/05/Diabsolut-Cloud-Logo-Web-1.png" width="277" height="81" data-no-retina="" style="height: 100%; width: 100%; text-align: left; line-height: 16px; letter-spacing: 0px; font-weight: 300; font-size: 12px; border-color: rgb(255, 255, 255); border-style: none; margin: 0px; border-radius: 0px; padding: 0px;" data-stylerecorder="true"> " & @CRLF & _
"" & @CRLF & _
"<img width="300" height="179" src="https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo-300x179.png" class="attachment-medium size-medium" alt="" srcset="https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo-300x179.png 300w, https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo.png 350w" sizes="(max-width: 300px) 100vw, 300px"></a></div><h4 style="text-align: center" class="vc_custom_heading vc_custom_1508180231294">Consulting Solutions</h4>" & @CRLF & _
"logout"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")