import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<=\")\\s*(?:https?)?:\\/\\/[^\"]+\\/(?=[^\"]*logo)[^\"]*(?:png|jpe?g|gif|tiff)\\s*(?=\")";
final String string = "<link rel=\"icon\" href=\"https://diabsolut.com/wp-content/uploads/2018/02/D-Logo-150x150.png\" sizes=\"32x32\">\n"
+ "<link rel=\"icon\" href=\"https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png\" sizes=\"192x192\">\n"
+ "<link rel=\"apple-touch-icon-precomposed\" href=\"https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png\">\n"
+ "<meta name=\"msapplication-TileImage\" content=\"https://diabsolut.com/wp-content/uploads/2018/02/D-Logo.png\">\n"
+ "<img width=\"200\" height=\"147\" src=\"https://diabsolut.com/wp-content/uploads/2017/05/Diabsolut-logo-01-e1496083111444.png\" class=\"attachment-large size-large\" alt=\"\">\n"
+ "<img src=\"https://diabsolut.com/wp-content/uploads/2019/03/White-FSM-logo.png\" width=\"330\" height=\"215\" data-no-retina=\"\" style=\"\">\n\n"
+ "<img src=\"https://diabsolut.com/wp-content/uploads/2017/05/Diabsolut-Cloud-Logo-Web-1.png\" width=\"277\" height=\"81\" data-no-retina=\"\" style=\"height: 100%; width: 100%; text-align: left; line-height: 16px; letter-spacing: 0px; font-weight: 300; font-size: 12px; border-color: rgb(255, 255, 255); border-style: none; margin: 0px; border-radius: 0px; padding: 0px;\" data-stylerecorder=\"true\"> \n\n"
+ "<img width=\"300\" height=\"179\" src=\"https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo-300x179.png\" class=\"attachment-medium size-medium\" alt=\"\" srcset=\"https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo-300x179.png 300w, https://diabsolut.com/wp-content/uploads/2017/05/Watershed-CI-Logo.png 350w\" sizes=\"(max-width: 300px) 100vw, 300px\"></a></div><h4 style=\"text-align: center\" class=\"vc_custom_heading vc_custom_1508180231294\">Consulting Solutions</h4>\n"
+ "logout";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}