$re = '/[A-Z]{3} \d \d{2} [A-Z] [A-Z]/mi';
$str = 'AMS 0 12 A B
GLA 1 H X
LHR 0 12 P Q
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);