// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[A-Z]{3} \d \d{2} [A-Z] [A-Z]").unwrap();
let string = "AMS 0 12 A B
GLA 1 H X
LHR 0 12 P Q
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}