using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|(\[)(?=\h*x\h*])|(?<=\[)\h*x\h*(]))";
string input = @"Yes: [x]
Yes: [ x]
Yes: [x ]
Yes: [ x ]
No: [
No: ]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}