$re = '/(?|(\[)(?=\h*x\h*])|(?<=\[)\h*x\h*(]))/';
$str = 'Yes: [x]
Yes: [ x]
Yes: [x ]
Yes: [ x ]
No: [
No: ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);