# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[^\\]*)\\t([^\\]*)\\t([^\\]*)\\t([^\\]*)\\t([^\\]*)(.*)"
test_str = ("19-22\\t\\t4\\tP,G\\tDOB_TT\\t\\tTime of Birth\\t\\t126\\t \\t0000-2359 Time of Birth\n"
"24-25\\t\\t2\\tT,G\\tOSTATE\\t\\tOccurrence Postal State\n"
"85-86\\t\\t2\\tG\\tMRCNTRY\\tMother’s Residence Country\\t\\tAA-ZZ\\tSee Geographic Documentation\n"
"87-88\\t\\t2\\tG\\tXMRSTATE\\tExpanded State of Residence of Mother\\t\\t\n"
"108-109\\t\\t2\\tP,G\\tMRACE_R15\\tMother’s Race Recode 15\\t\\t\\t\n"
"151-152\\t\\t2\\tP,G\\tFRACE_R31\\tFather’s Race Recode 31\\t\\t\\t01\\tWhite (only) [only one race reported]")
subst = "\\5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.