package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]{3})-([A-Z]{3})$`)
var str = `VIE-CAI
HAV-VRA
JFK-SYD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}