$re = '~^([A-Z]{3})-([A-Z]{3})$~m';
$str = 'VIE-CAI
HAV-VRA
JFK-SYD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);