#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d{2}/\d{2}/\d{4} -\d{2}:\d{2}(?!\d)([\s\S]*?)(?=\s*\b\d{2}/\d{2}/\d{4} -\d{2}:\d{2}(?!\d)|$)"
Local $sString = "25/03/2021 -11:42 ANTONIO LUCIVA SALDANHAALVES (472959COREN) ANTONIO LUCIVA SALDANHAALVES (472959COREN) ENFERMAGEMPCT JÁ ESTA DE ALTA HOSPITALAR MELHORADA,EM AGUARDO DO PAD PARA LIBERAÇÃO , NO QUAL ENFERMEIRO MANOEL VEIO AVALIAR CLIENTE ONDE O MESMO LIBEROU PARA ACOMPANHAMENTO DOMICILIAR. EVOLUI COM MELHORA SATISFATÓRIA,HUMOR PRESERVADO, CONSCIENTE,ORIENTADA, VERBALIZA, DEAMBULA SE NECESSÁRIO. NEGA DISPNEIA OU MAIORES QUEIXAS. ELIMINAÇÕES FISIOLOGICAS PRESENTES SEM ALTERAÇÕES. DESSA FORMA CLIENTE É LIBERADO E SERÁ ACOMPANHADA PELO (PAD). 25/03/2021 -08:22LIA FERNANDES ALVES DE LIMA (8308CRM)LIA FERNANDES ALVES DE LIMA (8308CRM)EM TEMPO SOLICITO EXAMES 25/03/2021 -08:20LIA FERNANDES ALVES DE LIMA (8308CRM)LIA FERNANDES ALVES DE LIMA (8308CRM)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")