import re
regex = re.compile(r"\b\d{2}/\d{2}/\d{4} -\d{2}:\d{2}(?!\d)([\s\S]*?)(?=\s*\b\d{2}/\d{2}/\d{4} -\d{2}:\d{2}(?!\d)|$)", flags=re.MULTILINE)
test_str = "25/03/2021 -11:42 ANTONIO LUCIVA SALDANHAALVES (472959COREN) ANTONIO LUCIVA SALDANHAALVES (472959COREN) ENFERMAGEMPCT JÁ ESTA DE ALTA HOSPITALAR MELHORADA,EM AGUARDO DO PAD PARA LIBERAÇÃO , NO QUAL ENFERMEIRO MANOEL VEIO AVALIAR CLIENTE ONDE O MESMO LIBEROU PARA ACOMPANHAMENTO DOMICILIAR. EVOLUI COM MELHORA SATISFATÓRIA,HUMOR PRESERVADO, CONSCIENTE,ORIENTADA, VERBALIZA, DEAMBULA SE NECESSÁRIO. NEGA DISPNEIA OU MAIORES QUEIXAS. ELIMINAÇÕES FISIOLOGICAS PRESENTES SEM ALTERAÇÕES. DESSA FORMA CLIENTE É LIBERADO E SERÁ ACOMPANHADA PELO (PAD). 25/03/2021 -08:22LIA FERNANDES ALVES DE LIMA (8308CRM)LIA FERNANDES ALVES DE LIMA (8308CRM)EM TEMPO SOLICITO EXAMES 25/03/2021 -08:20LIA FERNANDES ALVES DE LIMA (8308CRM)LIA FERNANDES ALVES DE LIMA (8308CRM)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")