$re = '/(.*(^|\s)foo(\s|\n).*)/';
$str = 'foo bar
only foo bar
only foo how
only foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);