re = /(.*(^|\s)foo(\s|\n).*)/
str = 'foo bar
only foo bar
only foo how
only foo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end