package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-9]{2})(0|1)([0-9])([0-3])([0-9]))([ ]?)(([0-9]{4})([ ]?)([0-1][8]([ ]?)[0-9]))`)
var str = `
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}