re = /(([0-9]{2})(0|1)([0-9])([0-3])([0-9]))([ ]?)(([0-9]{4})([ ]?)([0-1][8]([ ]?)[0-9]))/m
str = '
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end