const regex = /^[jJ]ohn.[sS]mith[^@]*@(?!mymail\.com).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[jJ]ohn.[sS]mith[^@]*@(?!mymail\\.com).+', 'gm')
const str = `John Smith (notmyemail@sodifh.com)
John Smith (notmyemail@SODI.com)
John Smith (jsmit34@gmail.com)
John Smith (myRealEmail@mymail.com)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}