import re
regex = re.compile(r"^[jJ]ohn.[sS]mith[^@]*@(?!mymail\.com).+", flags=re.MULTILINE)
test_str = ("John Smith (notmyemail@sodifh.com)\n"
"John Smith (notmyemail@SODI.com)\n"
"John Smith (jsmit34@gmail.com)\n"
"John Smith (myRealEmail@mymail.com)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")