package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)[:<>]([^,\n]+)`)
var str = `firstName:Giorgio,
email:giorgio.rossi@libero.it,
dataregistrazione:27/10/2016,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}