package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S+) (\S*) ?\b(\S+)`)
var str = `foo it's`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}