using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"YOUR REGEX HERE";
string input = @"should match: moon, moooon, moooooon, muun, muuuun, moon, moooon
should not match: mn, mooon, mon, mun, muu, oooooon, moouun";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}